Instalacia/ aktualizacia modulov problem s SSL


#1

Dobry den,

s drupalom vo volnom case uz pracujem par rokov ale momentalne som uz bezradny.
Na instalaciu modulov a nasledne ich aktualizacie som pouzival klasicke webove rozhranie drupalu, no
v sucastnosti bez toho aby som nemal https protokol co znamena SSL certifikat vyhodi chybu ze sa nepripoji na vzdialeny
server.

este chybova hlaska

Failed to fetch file due to error "Error creating resource: [message] fopen(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed [file] D:\work\web\pages\sugarovci02.sk\www\vendor\guzzlehttp\guzzle\src\Handler\StreamHandler.php [line] 312 [message] fopen(): Failed to enable crypto [file] D:\work\web\pages\sugarovci02.sk\www\vendor\guzzlehttp\guzzle\src\Handler\StreamHandler.php [line] 312 [message] fopen(https://ftp-origin.drupal.org/files/projects/paragraphs-8.x-1.1.tar.gz): failed to open stream: operation failed [file] D:\work\web\pages\sugarovci02.sk\www\vendor\guzzlehttp\guzzle\src\Handler\StreamHandler.php [line] 312"
Unable to retrieve Drupal project from http://ftp.drupal.org/files/projects/paragraphs-8.x-1.1.tar.gz.

je to niak mozne obist aby respektoval http protokol ? .

dakujem za pomoc alebo aspom nasmerovanie :slight_smile:


#2

Ahoj,

skus prepnut radsej na composer, instalovanie cez rozhranie nie je najlepsie riesenie.
Tvoju chybu by malo fixnut toto https://stackoverflow.com/a/39807251


#3

Ďakujem za odpoveď, každopadne danu chybu to neodstranilo.

mam to nastavene podla tohto tutorialu


cize v php.ini mam
openssl.cafile = “c:/OpenSSL-Win64/bin/certificate.crt”

Cize ssl certifikat funguje ale som si ho sam vytvoril a je vyhodnocovany ako nedoveryhodny.
Necham to tak … a idem skusit ten composer. Ked bude vsetko funkcne a stranka by aj realne fungovala budem zvazovat dalej samotny SSL certifikat zakupit.

Dakujem


#4

Tak som sa rozhodol pre composer, kedze v minulosti som ho ciastocne pouzival na ine projekty, mal som ho nainstalovany. V minulosti vsetko fungovalo. momentalne mi hlasi tu istu chybu s overenim certifikatu.

tak som sa rozhodol vsetko odinstalovat. PHP Apache Mysql a nainstalovat novu verziu WAMP serveru so vsetkymi najnovsimi sucastami.

Aktualnu verziu Composeru sa mi nepodarilo ani nainstalovat …

The “https://getcomposer.org/versions” file could not be downloaded: SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
Failed to enable crypto
failed to open stream: operation failed

ja uz neviem … co s tym mam … :frowning:


#5

Google ti co poradil? Ja som nasiel toto https://github.com/composer/composer/issues/3950 https://github.com/composer/composer/issues/2798. V podstate rovnaky postup - je potrebne si stiahnut certifikaty z linku, co je tam spomenuty, nastavit ich v php.ini a malo by to ist. Odporucam sa este opytat na Slacku - pozvanka isla pred par dnami.


#6

Dakujem za odpoved, uz som na to prisiel a je to pre uplne inu vec.

V najnovsej aktualizaciii Esetu pribudlo blokovanie komunikacie pokial ide o nedoveryhodny certifikat.
Ked som toto “vylepsenie” vypol vsetko vyzera ze funguje.

Composer som nainstaloval, moduly som cez neho nainstaloval tiez atd …

Este raz dakujem


#7

Super, dobre vediet :wink: